Discussing: The Steam Version of Grand Theft Auto: Vice City

This is mostly me complaining so you’ve been warned.

I had so much trouble trying to play my copy of Grand Theft Auto: Vice City on Steam. I used to play it just fine before but around two years ago, it just stopped working. Recently, I decided I wanted to finally beat Vice City for the first time. I usually just did some of the early missions and got lost causing general chaos. I heard that there was a recent update by Rockstar that fixed some issues so I thought that the problem would have been fixed. Turns out that wasn’t the case as it still wouldn’t load to the main menu. I kept getting an “insert disc” error message. So I checked out the PC gaming wiki and found out that it was because the game was installed on a different hard drive. I have a 3 TB hard drive I install all my games on but one game won’t hurt.

So I install the game on my primary hard drive and the game loads up on the main menu. However, while I’m scrolling through the menus, adjusting video settings, I noticed that my mouse clicks weren’t registering. Pressing Enter was working fine but not my mouse clicks. I ignored it at first but when I got into the game, the camera wasn’t moving when I moved the mouse and I couldn’t punch. It was as if my mouse wasn’t even plugged in. Also, my car wouldn’t go in reverse and I was getting some weird glitches in the graphics and frame rate. Going back to the PC gaming wiki, apparently I have to put on the Frame Limiter option because when the game runs at a frame rate higher than 30, it freaks out.

So I turn on Frame Limiter, and that fixed the glitches, the frame rate and going in reverse. However, the mouse still wasn’t registering. Back to the PC gaming wiki. I found several options: refreshing the desktop, disabling the steam overlay, download a dinput.dll file, etc. None of them worked. At this point, I gave up and uninstalled it until about a week and a half ago. I did some searching online and found some mods that allowed me to use a Xbox 360 controller (fully) and updated the graphics. This finally gave me a game that I can play, which I’ve been doing.

However, what pisses me off is I should not of had to do any of that. I bought Vice City a long time ago and it shouldn’t matter that it’s a 12 year old game when I want to fire it up. I now have a game that I paid money for that doesn’t work unless I use unofficial means. I was contemplating buying the PS2 version on the PlayStation Network via the PS3 but I felt indignant about it. Why should I buy this game that I already own but doesn’t work because some didn’t keep their shit working? I know that older games on the PC don’t work anymore but Rockstar is still selling Vice City and there’s no mention of any problems on the store page on Steam. Not to mention that we’re in an era of video games where games are supported long after their initial release. Case in point: Rockstar just updated San Andreas to REMOVE songs from the game. So it’s not like they can’t update it. I should mention that I have to use a controller to play the game. Mouse still doesn’t work.

Anyways, I wanted to rant about the crap I was dealing with trying to get this game running. I want to hear from you though. Have you had any trouble with playing Vice City on Steam? Did you get it working? Any tips on how to get Vice City working better? Say it all in the comments section. Peace and love, gamers and players. Colorwind out!

Advertisements

You talking to me? Are you...talking to me?

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s